OpenSSL 3.2.0 正式版发布,客户端 QUIC 支持 / 证书压缩 / 支持原始公钥等
发表于:2026-11-04 作者:千家信息网编辑
千家信息网最后更新 2026年11月04日,感谢CTOnews.com网友 Alejandro86、Coje_He 的线索投递!CTOnews.com 11 月 26 日消息,OpenSSL 是一个强大的安全套接字层密码库,囊括主要的密码算法、
千家信息网最后更新 2026年11月04日OpenSSL 3.2.0 正式版发布,客户端 QUIC 支持 / 证书压缩 / 支持原始公钥等
感谢CTOnews.com网友 Alejandro86、Coje_He 的线索投递!
CTOnews.com 11 月 26 日消息,OpenSSL 是一个强大的安全套接字层密码库,囊括主要的密码算法、常用的密钥和证书封装管理功能及 SSL 协议,并提供丰富的应用程序供测试或其它目的使用。
OpenSSL 3.2.0 版本现已发布,这是 OpenSSL 3.2 系列的首个通用版本,并包含许多新功能,CTOnews.com下面列举一些重要更新:
默认 SSL / TLS 安全级别从 1 改为 2。
客户端 QUIC 支持,包括对多个流的支持(RFC 9000)
TLS 中的证书压缩(RFC 8879),包括对 zlib、zstd 和 Brotli 的支持
确定性 ECDSA(RFC 6979)
除了对 Ed25519 和 Ed448 的现有支持外,现在还支持 Ed25519ctx、Ed25519ph、Ed448ph(RFC 8032)
支持 AES-GCM-SIV(RFC 8452)
支持 Argon2(RFC 9106)和线程池功能
HPKE(RFC 9180)
在 TLS 中使用原始公钥的能力(RFC 7250)
支持 TCP Fast Open(RFC 7413)
支持基于提供者的可插拔签名方案在 TLS 中的使用,允许第三方后量子和其他算法提供者将算法与 TLS 一起使用。
支持在 TLS 1.3 中使用 Brainpool 曲线。
支持 SM4-XTS
支持使用 Windows 系统证书存储作为可信根证书的来源。目前默认情况下尚未启用,必须通过环境变量激活。在未来的功能发布中可能会默认启用。
支持
证书
功能
算法
安全
密码
提供者
版本
原始
公钥
客户
客户端
强大
重要
变量
可信
多个
套接字
密钥
尚未
数据库的安全要保护哪些东西
数据库安全各自的含义是什么
生产安全数据库录入
数据库的安全性及管理
数据库安全策略包含哪些
海淀数据库安全审计系统
建立农村房屋安全信息数据库
易用的数据库客户端支持安全管理
连接数据库失败ssl安全错误
数据库的锁怎样保障安全
互联网科技公司简介
科技互联网龙头
麻工互联网科技
喔噻互联网科技
华中科技大学互联网
百单互联网科技有限公司
人人互联网科技是培训
科技伦理 互联网公司
山东吉时兔互联网科技有限公司
现代科技和互联网有关系吗
哈尔滨新华互联网科技学院
中国的互联网科技企业的崛起
互联网科技中介
互联网为啥属于高科技
黑科技闪耀互联网之光
上海科技产业互联网平台
互联网营销推广黑科技
四川互联网展示科技馆设计
易企秀互联网科技是做什么的
保山浩联互联网科技有限公司
手冲咖啡和咖啡机区别
互联网电商科技
互联网巨头科技公司
互联网科技金融
善班互联网科技
云电互联网科技
广州紫鲸互联网科技
互联网科技英文翻译
深圳国际航运科技和互联网
北京瑞云互联网科技有限公司
相关文章
- 25 周年纪念作,情怀拉满但诚意欠缺:《勇者斗恶龙 怪物仙境 3》
- 联想拯救者 Y700 2023 平板推送 ZUI 15.0.723 系统灰度测试:新增“USB 网络共享”,优化底部小白条
- Streacom 推出 SG10 高端被动散热机箱:可解热 600W,1300 美元
- 3D 角色扮演策略游戏《少女前线 2:追放》公测开启,安卓、iOS、PC 多端互通
- 新能源车市:价格战开局,价值战结束
- 雪天这样拍,照片更为味道
- Cybertruck:未来物种重新定义汽车
- 2022 年我国未成年网民规模突破 1.93 亿,普及率达 97.2%
- 上映 7 天,《名侦探柯南:黑铁的鱼影》内地票房破亿、豆瓣 6.6 分
- 小岛工作室推出《死亡搁浅》联名手机手柄,预计明年发售